using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^_]+_){2}(\d+)";
string input = @"XXXXX_20160207_20180208_XXXXXXX_20190408T160742_xxxxx";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}