package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:[^_]+_){2}(\d+)`)
var str = `XXXXX_20160207_20180208_XXXXXXX_20190408T160742_xxxxx`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}