re = /^(?:[^_]+_){2}(\d+)/
str = 'XXXXX_20160207_20180208_XXXXXXX_20190408T160742_xxxxx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end