const regex = /^(?:[^_]+_){2}(\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[^_]+_){2}(\\d+)', 'g')
const str = `XXXXX_20160207_20180208_XXXXXXX_20190408T160742_xxxxx`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}