#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\S)[a-zA-Z\d]+(?:[.-][a-zA-Z\d]+)?(?!\S)"
Local $sString = "ab.ab" & @CRLF & _
"ab.ab.ab" & @CRLF & _
"ab." & @CRLF & _
".ab" & @CRLF & _
".Ab" & @CRLF & _
"Ab." & @CRLF & _
"Ab.A" & @CRLF & _
"ab" & @CRLF & _
"a" & @CRLF & _
"sample text ..teste...tetes ab. .ab test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")