$re = '/(?<!\S)[a-zA-Z\d]+(?:[.-][a-zA-Z\d]+)?(?!\S)/m';
$str = 'ab.ab
ab.ab.ab
ab.
.ab
.Ab
Ab.
Ab.A
ab
a
sample text ..teste...tetes ab. .ab test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);