const regex = new RegExp('(?<!\\S)[a-zA-Z\\d]+(?:[.-][a-zA-Z\\d]+)?(?!\\S)', 'gm')
const str = `ab.ab
ab.ab.ab
ab.
.ab
.Ab
Ab.
Ab.A
ab
a
sample text ..teste...tetes ab. .ab test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}