re = /(?<!\S)[a-zA-Z\d]+(?:[.-][a-zA-Z\d]+)?(?!\S)/m
str = 'ab.ab
ab.ab.ab
ab.
.ab
.Ab
Ab.
Ab.A
ab
a
sample text ..teste...tetes ab. .ab test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end