using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[A-Za-z]{3,4}\d{3})";
string input = @"Thomas Hawk AQWS456
Cecile Star RQWS456
Mickey Mouse WQWS456
Donald Duck SQWS456";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}