$re = '/(?:[A-Za-z]{3,4}\d{3})/m';
$str = 'Thomas Hawk AQWS456
Cecile Star RQWS456
Mickey Mouse WQWS456
Donald Duck SQWS456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);