// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:[A-Za-z]{3,4}\d{3})").unwrap();
let string = "Thomas Hawk AQWS456
Cecile Star RQWS456
Mickey Mouse WQWS456
Donald Duck SQWS456";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}