import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[A-Za-z]{3,4}\\d{3})";
final String string = "Thomas Hawk AQWS456\n"
+ "Cecile Star RQWS456\n"
+ "Mickey Mouse WQWS456\n"
+ "Donald Duck SQWS456";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}