using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?#leftside)[a-zA-Z][a-zA-Z0-9]*((\s)*\[(\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*)((\s)*[+*\/-](\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*))*(\s)*\])?(?#rightside)(\s)*=(\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*((\s)*\[(\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*)((\s)*[+*\/-](\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*))*(\s)*\]|(?#idk)(\s)*\((\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*)((\s)*[,+*\/-](\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*))*(\s)*\))?)((\s)*[+*\/-](\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*((\s)*\[(\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*)((\s)*[+*\/-](\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*))*(\s)*\]|(\s)*\((\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*)((\s)*[,+*\/-](\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*))*(\s)*\))?))*(\s)*;";
string input = @"hello>a=18;a=rrr
846y=t+2;h4r890a*=10;xd[b]=7;
s=a;g=yur;d=q::*f=w(hhfu;
f = b[p-9];uti_*s=f(fr+2);";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}