// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?#leftside)[a-zA-Z][a-zA-Z0-9]*((\s)*\[(\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*)((\s)*[+*\/-](\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*))*(\s)*\])?(?#rightside)(\s)*=(\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*((\s)*\[(\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*)((\s)*[+*\/-](\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*))*(\s)*\]|(?#idk)(\s)*\((\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*)((\s)*[,+*\/-](\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*))*(\s)*\))?)((\s)*[+*\/-](\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*((\s)*\[(\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*)((\s)*[+*\/-](\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*))*(\s)*\]|(\s)*\((\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*)((\s)*[,+*\/-](\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*))*(\s)*\))?))*(\s)*;").unwrap();
let string = "hello>a=18;a=rrr
846y=t+2;h4r890a*=10;xd[b]=7;
s=a;g=yur;d=q::*f=w(hhfu;
f = b[p-9];uti_*s=f(fr+2);";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}