package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?#leftside)[a-zA-Z][a-zA-Z0-9]*((\s)*\[(\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*)((\s)*[+*\/-](\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*))*(\s)*\])?(?#rightside)(\s)*=(\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*((\s)*\[(\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*)((\s)*[+*\/-](\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*))*(\s)*\]|(?#idk)(\s)*\((\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*)((\s)*[,+*\/-](\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*))*(\s)*\))?)((\s)*[+*\/-](\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*((\s)*\[(\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*)((\s)*[+*\/-](\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*))*(\s)*\]|(\s)*\((\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*)((\s)*[,+*\/-](\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*))*(\s)*\))?))*(\s)*;`)
var str = `hello>a=18;a=rrr
846y=t+2;h4r890a*=10;xd[b]=7;
s=a;g=yur;d=q::*f=w(hhfu;
f = b[p-9];uti_*s=f(fr+2);`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}