# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?#leftside)[a-zA-Z][a-zA-Z0-9]*((\s)*\[(\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*)((\s)*[+*\/-](\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*))*(\s)*\])?(?#rightside)(\s)*=(\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*((\s)*\[(\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*)((\s)*[+*\/-](\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*))*(\s)*\]|(?#idk)(\s)*\((\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*)((\s)*[,+*\/-](\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*))*(\s)*\))?)((\s)*[+*\/-](\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*((\s)*\[(\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*)((\s)*[+*\/-](\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*))*(\s)*\]|(\s)*\((\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*)((\s)*[,+*\/-](\s)*([0-9]+|[a-zA-Z][a-zA-Z0-9]*))*(\s)*\))?))*(\s)*;"
test_str = ("hello>a=18;a=rrr\n\n"
"846y=t+2;h4r890a*=10;xd[b]=7;\n\n"
"s=a;g=yur;d=q::*f=w(hhfu;\n\n"
"f = b[p-9];uti_*s=f(fr+2);")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.