using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"j(ava)?( )?s(cript)?";
string input = @"Coucou Javascript Java script JavaScript Java Script Js JS javascript java script javaScript java Script js ça va ?";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}