// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)j(ava)?( )?s(cript)?").unwrap();
let string = "Coucou Javascript Java script JavaScript Java Script Js JS javascript java script javaScript java Script js ça va ?";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}