re = /j(ava)?( )?s(cript)?/im
str = 'Coucou Javascript Java script JavaScript Java Script Js JS javascript java script javaScript java Script js ça va ?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end