$re = '/j(ava)?( )?s(cript)?/im';
$str = 'Coucou Javascript Java script JavaScript Java Script Js JS javascript java script javaScript java Script js ça va ?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);