package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:\d+|\d{1,3}(?:,\d{3})*)\R){2,}`)
var str = `Peie
71,176,953
T-re
71,173,557
5-Mts
41,653,495
45678
Sia
36,136,829
36,100,829
4-Diepi
120,829
uteCra
36,100
Oct2018
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}