import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:\\d+|\\d{1,3}(?:,\\d{3})*)\\R){2,}";
final String string = "Peie\n"
+ "71,176,953\n"
+ "T-re\n"
+ "71,173,557\n"
+ "5-Mts\n"
+ "41,653,495\n"
+ "45678\n"
+ "Sia\n"
+ "36,136,829\n"
+ "36,100,829\n"
+ "4-Diepi\n"
+ "120,829\n"
+ "uteCra\n"
+ "36,100\n"
+ "Oct2018\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}