# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?:\d+|\d{1,3}(?:,\d{3})*)\R){2,}"
test_str = ("Peie\n"
"71,176,953\n"
"T-re\n"
"71,173,557\n"
"5-Mts\n"
"41,653,495\n"
"45678\n"
"Sia\n"
"36,136,829\n"
"36,100,829\n"
"4-Diepi\n"
"120,829\n"
"uteCra\n"
"36,100\n"
"Oct2018\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.