const regex = /^(?:(?:\d+|\d{1,3}(?:,\d{3})*)\R){2,}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:\\d+|\\d{1,3}(?:,\\d{3})*)\\R){2,}', 'gm')
const str = `Peie
71,176,953
T-re
71,173,557
5-Mts
41,653,495
45678
Sia
36,136,829
36,100,829
4-Diepi
120,829
uteCra
36,100
Oct2018
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}