import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*[a-z]{3})(?=.*[\\d])(?=.*[A-Z])(?=.*[a-z]{2})(?=.*[@#$])[\\w\\d@#$]{6,12}$";
final String string = "Massas23#\n"
+ "Mas23#";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}