$re = '/^(?!.*[a-z]{3})(?=.*[\d])(?=.*[A-Z])(?=.*[a-z]{2})(?=.*[@#$])[\w\d@#$]{6,12}$/m';
$str = 'Massas23#
Mas23#';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;