re = /^(?!.*[a-z]{3})(?=.*[\d])(?=.*[A-Z])(?=.*[a-z]{2})(?=.*[@#$])[\w\d@#$]{6,12}$/m
str = 'Massas23#
Mas23#'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result