import re
regex = re.compile(r"^(?!.*[a-z]{3})(?=.*[\d])(?=.*[A-Z])(?=.*[a-z]{2})(?=.*[@#$])[\w\d@#$]{6,12}$", flags=re.MULTILINE)
test_str = ("Massas23#\n"
"Mas23#")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)