#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/$|(\/[a-zA-Z_0-9-]+)+$"
Local $sString = "/" & @CRLF & _
"/abc" & @CRLF & _
"/sab_" & @CRLF & _
"/abc/abc/" & @CRLF & _
"/sad/dfsd" & @CRLF & _
"" & @CRLF & _
"null" & @CRLF & _
"/dsf/dfsdf/dsfsf/sdfds" & @CRLF & _
"/e3r/343/8437" & @CRLF & _
"/4333/32#" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")