// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\/$|(\/[a-zA-Z_0-9-]+)+$").unwrap();
let string = "/
/abc
/sab_
/abc/abc/
/sad/dfsd
null
/dsf/dfsdf/dsfsf/sdfds
/e3r/343/8437
/4333/32#
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}