re = /^\/$|(\/[a-zA-Z_0-9-]+)+$/m
str = '/
/abc
/sab_
/abc/abc/
/sad/dfsd
null
/dsf/dfsdf/dsfsf/sdfds
/e3r/343/8437
/4333/32#
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end