using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)name\s*=\s*['""]?news_keywords[^>]+content\s*=\s*['""]?([^'""]*)['""]?|content\s*=\s*['""]?([^""']*)['""]?[^>]+name\s*=\s*['""]?news_keywords['""]?";
string input = @" <meta name=""keywords"" content=""People, Royals"" />
<meta name=""news_keywords"" content=""william,george,charlotte,kate middleton,prinz george,prinz,prinzessin charlotte,royal-family,marys hospitals,royal-fans"" />
<meta name=""author"" content=""Blick"" />
<meta name=""date"" content=""2018-04-23T14:20:42+0200"" />
<meta name=""robots"" content=""index,follow,noodp,noarchive"" />
<meta name=""contentId"" content=""8171954"" />
<meta name=""cXenseParse:recs:articleid"" content=""8171954""/>
<meta name=""contentType"" content=""news"" />
<meta name=""cXenseParse:rag-pagetype"" content=""news""/>
<meta name=""contentPool"" content=""web|mobile|app"" />
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}