const regex = /(?i)name\s*=\s*['"]?news_keywords[^>]+content\s*=\s*['"]?([^'"]*)['"]?|content\s*=\s*['"]?([^"']*)['"]?[^>]+name\s*=\s*['"]?news_keywords['"]?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)name\\s*=\\s*[\'"]?news_keywords[^>]+content\\s*=\\s*[\'"]?([^\'"]*)[\'"]?|content\\s*=\\s*[\'"]?([^"\']*)[\'"]?[^>]+name\\s*=\\s*[\'"]?news_keywords[\'"]?', 'g')
const str = ` <meta name="keywords" content="People, Royals" />
<meta name="news_keywords" content="william,george,charlotte,kate middleton,prinz george,prinz,prinzessin charlotte,royal-family,marys hospitals,royal-fans" />
<meta name="author" content="Blick" />
<meta name="date" content="2018-04-23T14:20:42+0200" />
<meta name="robots" content="index,follow,noodp,noarchive" />
<meta name="contentId" content="8171954" />
<meta name="cXenseParse:recs:articleid" content="8171954"/>
<meta name="contentType" content="news" />
<meta name="cXenseParse:rag-pagetype" content="news"/>
<meta name="contentPool" content="web|mobile|app" />
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}