# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)name\s*=\s*['\"]?news_keywords[^>]+content\s*=\s*['\"]?([^'\"]*)['\"]?|content\s*=\s*['\"]?([^\"']*)['\"]?[^>]+name\s*=\s*['\"]?news_keywords['\"]?"
test_str = (" <meta name=\"keywords\" content=\"People, Royals\" />\n"
" <meta name=\"news_keywords\" content=\"william,george,charlotte,kate middleton,prinz george,prinz,prinzessin charlotte,royal-family,marys hospitals,royal-fans\" />\n"
" <meta name=\"author\" content=\"Blick\" />\n"
"<meta name=\"date\" content=\"2018-04-23T14:20:42+0200\" />\n"
"<meta name=\"robots\" content=\"index,follow,noodp,noarchive\" />\n"
" <meta name=\"contentId\" content=\"8171954\" />\n"
" <meta name=\"cXenseParse:recs:articleid\" content=\"8171954\"/>\n"
"<meta name=\"contentType\" content=\"news\" />\n"
" <meta name=\"cXenseParse:rag-pagetype\" content=\"news\"/>\n"
"<meta name=\"contentPool\" content=\"web|mobile|app\" />\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.