package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)name\s*=\s*['"]?news_keywords[^>]+content\s*=\s*['"]?([^'"]*)['"]?|content\s*=\s*['"]?([^"']*)['"]?[^>]+name\s*=\s*['"]?news_keywords['"]?`)
var str = ` <meta name="keywords" content="People, Royals" />
<meta name="news_keywords" content="william,george,charlotte,kate middleton,prinz george,prinz,prinzessin charlotte,royal-family,marys hospitals,royal-fans" />
<meta name="author" content="Blick" />
<meta name="date" content="2018-04-23T14:20:42+0200" />
<meta name="robots" content="index,follow,noodp,noarchive" />
<meta name="contentId" content="8171954" />
<meta name="cXenseParse:recs:articleid" content="8171954"/>
<meta name="contentType" content="news" />
<meta name="cXenseParse:rag-pagetype" content="news"/>
<meta name="contentPool" content="web|mobile|app" />
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}