const regex = /[^\p{L}\p{Nd}]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\p{L}\\p{Nd}]', 'gm')
const str = `Rosną Na Łąkach - 012. !\$#%^`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);