re = /[^\p{L}\p{Nd}]/m
str = 'Rosną Na Łąkach - 012. !$#%^'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result