import re
regex = re.compile(r"[^\p{L}\p{Nd}]", flags=re.MULTILINE)
test_str = "Rosną Na Łąkach - 012. !$#%^"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)