$re = '/[^\p{L}\p{Nd}]/m';
$str = 'Rosną Na Łąkach - 012. !$#%^';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;