using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(0092|\+92|92|0)313(9([0-9][0-9])|5([0-9][0-9])|0(0[59]|1[59]|2[6789]|5[01234567]|8[56789]|9[01278934])|1(2[6789]|5[01234567]|8[56789]|9[0-9]))[0-9]{4}$";
string input = @"03135082344";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}