package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(0092|\+92|92|0)313(9([0-9][0-9])|5([0-9][0-9])|0(0[59]|1[59]|2[6789]|5[01234567]|8[56789]|9[01278934])|1(2[6789]|5[01234567]|8[56789]|9[0-9]))[0-9]{4}$`)
var str = `03135082344`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}