// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(0092|\+92|92|0)313(9([0-9][0-9])|5([0-9][0-9])|0(0[59]|1[59]|2[6789]|5[01234567]|8[56789]|9[01278934])|1(2[6789]|5[01234567]|8[56789]|9[0-9]))[0-9]{4}$").unwrap();
let string = "03135082344";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}