$re = '/^(0092|\+92|92|0)313(9([0-9][0-9])|5([0-9][0-9])|0(0[59]|1[59]|2[6789]|5[01234567]|8[56789]|9[01278934])|1(2[6789]|5[01234567]|8[56789]|9[0-9]))[0-9]{4}$/';
$str = '03135082344';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);