import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http|https):\\/\\/(m.|)mercedesbenzme.com\\/(.*)\\/(en|ar)\\/sedans-coupes\\/c-class\\/cabriolet\\/?$";
final String string = "https://m.mercedesbenzme.com/me/en/sedans-coupes/c-class/cabriolet/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}