$re = '/(http|https):\/\/(m.|)mercedesbenzme.com\/(.*)\/(en|ar)\/sedans-coupes\/c-class\/cabriolet\/?$/';
$str = 'https://m.mercedesbenzme.com/me/en/sedans-coupes/c-class/cabriolet/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);