re = /(http|https):\/\/(m.|)mercedesbenzme.com\/(.*)\/(en|ar)\/sedans-coupes\/c-class\/cabriolet\/?$/
str = 'https://m.mercedesbenzme.com/me/en/sedans-coupes/c-class/cabriolet/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end