// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(http|https):\/\/(m.|)mercedesbenzme.com\/(.*)\/(en|ar)\/sedans-coupes\/c-class\/cabriolet\/?$").unwrap();
let string = "https://m.mercedesbenzme.com/me/en/sedans-coupes/c-class/cabriolet/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}