using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Ben likes (bananas|mangoes|plums)\.";
string input = @"Ben likes bananas.
Ben likes mangoes.
Ben likes plums.
Ben likes oranges.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}