re = /Ben likes (bananas|mangoes|plums)\./m
str = 'Ben likes bananas.
Ben likes mangoes.
Ben likes plums.
Ben likes oranges.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end