package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Ben likes (bananas|mangoes|plums)\.`)
var str = `Ben likes bananas.
Ben likes mangoes.
Ben likes plums.
Ben likes oranges.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}